Toutes les clefs pour réussir dans le e-commerce

Mes modules Prestashop

Un slideshow gratuit pour prestashop 1.5

je vous présente ici un module que j’ai développé. Il est compatible avec Prestashop 1.5.x et vous permettra d’afficher un slideshow sur votre page d’accueil.

J’ai utilisé l’excellent script “coin slider” pour gérer les transitions entre les images.
Il est donc possible de choisir parmi trois effets de transition, vous aurez également la possibilité de créer plusieurs slideshow au cas où vous voudriez en afficher plusieurs sur votre page d’accueil ou simplement pour les préparer à l’avance et les activer en un clic. De nombreux réglages sont disponibles comme par exemple le temps d’affichage des images, la vitesse de la transition, etc…
Enfin pour chaque image vous pouvez ajouter une description et un lien afin d’amener vos visiteurs vers vos produits.

Le module est totalement gratuit il suffit d’aller sur la boutique pour le télécharger.

Poster un Commentaire

53 Commentaires sur "Un slideshow gratuit pour prestashop 1.5"

Recevoir un email pour
avatar
Trier par:   plus récent | plus vieux | Plus de vote
Yves
Invité

Excellent module, très pro et ça marche impeccable.

Attention : pour les futurs utilisateurs, j’ai eu du mal à trouver la configuration : cela se fait dans un onglet en haut de l’administration prestashop

A consommer sans modération…

Merci !

Julien
Invité
Julien

J’ai une erreur lorsque j’essai de l’installer

Je suis sous PrestaShop™ 1.5.4.0

“[PrestaShopException]

Property Tab->name is empty
at line 874 in file classes/ObjectModel.php

868.
869. $message = $this->validateField($field, $value, $id_lang);
870. if ($message !== true)
871. {
872. if ($die)
873. throw new PrestaShopException($message);
874. return $error_return ? $message : false;
875. }
876. }
877. }
878.

ObjectModelCore->validateFieldsLang – [line 306 – classes/ObjectModel.php] – [0 Argument]
ObjectModelCore->getFieldsLang – [line 490 – classes/ObjectModel.php] – [0 Argument]
ObjectModelCore->add – [line 99 – classes/Tab.php] – [2 Arguments]
TabCore->add – [line 47 – modules/opartslideshow/opartslideshow.php] – [0 Argument]
Opartslideshow->install – [line 677 – controllers/admin/AdminModulesController.php] – [0 Argument]
AdminModulesControllerCore->postProcessCallback – [line 797 – controllers/admin/AdminModulesController.php] – [0 Argument]
AdminModulesControllerCore->postProcess – [line 158 – classes/controller/Controller.php] – [0 Argument]
ControllerCore->run – [line 349 – classes/Dispatcher.php] – [0 Argument]
DispatcherCore->dispatch – [line 50 – admin_ps/index.php] – [0 Argument]”

Cordialement,
Julien

biv
Invité

peut-on afficher ce module sur d’autre page a l’expetion du page d’acceuil?

Vio75020
Invité
Vio75020

Bonjour,
J’ai installé dans ma boutique PS 1.5.3.1 votre module en page d’accueil avec 2 autres modules de sliders (celui de Prestashop et le Minic Slider). Cela fonctionne très bien sur tous les navigateurs, sauf sur Internet Explorer. Avez-vous déjà eu le cas et si oui savez vous comment je peux régler le problème ?

Merci
Vio75020

vio75020
Invité
vio75020

Bonjour,

Le voici http://www.horsessentials.com (le Op’Art est le slider en bas à droite). En plus, je crois que votre slider fait disfonctionner mon menu horizontal Mega Drown (seulement sur IE). Quand je le désactive, le menu horizontal s’affiche normalement.

Le tout fonctionne bien sur Chrome, Firefox, Safari.

Merci
Vio75020

vio75020
Invité
vio75020

J’ai un peu creusé et cela semble provenir d’un conflit de bibliothèque jquery qui n’est pas bien géré

Ligara France
Invité

bonjour
comment on peut accrocher votre module sur header ou top of pages? Actuellemnt il est accroche sur la colonne centrale de Homepage, maois nous souhaitons le placer au-dessus de homepage, c’est à dire au dessus de 3 colonnes juste au-dessous de la bannière du site Merci pour votre conseil

Vio
Invité
Vio

Bonsoir,

Concernant mon problème avec Internet Explorer, j’ai découvert sur un forum que IE ne prend en compte que 31 fichiers CSS externes. En activant le CCC (Concaténation, Compression et mise en Cache), Smart Cache pour les fichiers CSS dans le menu “Performances” de Prestashop 1.5.3, le problème de non prise en compte des CSS est résolu.

Merci pour votre aide

Vio75020

Alex72
Invité

Bonjour,

Je vien d’installer le module sur mon site.
Il est vraiment super, mais j’ai un problem de fonctionnement sous IE 9, voici le liens du site en question : http://www.sanithermelec.fr

Si quelqu’un pouvais regarder !

Merci

Alex72
Invité

Bonjour maniT4c,

Oupss alors !!!
Chez moi cela ne fonction pas sous IE 9, c’est quand meme bizarre, alors que sous CHROME je n’est pas de PB

JE vais essayer ce midi sur un autre poste.

Merci de ta reponse, je te tiens au courant.

Alex72
Invité

Re bonjour maniT4c

Je confirme, j’ai le même soucis sur deux autres poste avec IE 9 !!
Javascript activé sur les trois postes et mode CCC activé dans le SMART CACHE des performance PRESTASHOP.

Je ne vois pas d’ou cela peut venir !

Alex72
Invité

Je te remercie pour ta reponse, je fait le test ce soir, car en déplacement actuellement et je ne peut pas faire cette modif.

Je te tiens au courant.

Merci encore pour ta rapidité de réponse,

Alex72
Invité

MERCIIIIIIIIIIII

Tu est vraiment super, cela fonctionne maintenant à merveille.
Mon site http://www.sanithermelec.fr peux enfin avoir des petites pub tournantes.

J’aurais une dernière question, comment je peux faire pour afficher les pub en permanence, lorsqu’elle sont dans les colonnes droite ou gauche ?

Merci encore pour ta rapidité de réponse

Alex72
Invité

Oupssss !!!

C’est bons j’avais pas tous lu dans la doc.

Merci

benoit
Invité

bonjour,

je rencontre un problème également avec le fonctionnement du slideshow sous internet explorer (j’ai testé sous le 8 et le 9 mais le problème persiste sur les deux versions), il ne fonctionne pas du tout. Les images se mettent les unes en dessous des autres et j’ai l’impression que ma page n’a pas fini de se charger correctement. J’ai téléchargé la dernière version sur votre site fixant un bug sous IE 9, j’ai également vérifié qu’il n’y avait pas de console.log mais rien n’y fait.

Cordialement,

benoit
Invité

bonsoir,

J’ai résolu le problème cela vient d’une virgule en trop dans le fichier slideshow.tpl et slideshowTop.tpl situé dans views/templates/hook, il ne faut pas mettre de virgule au dernier argument sinon sa ne fonctionne pas sous IE et il renvoit l’erreur suivante : SCRIPT1028: Identificateur, chaîne ou nombre attendu

Bonne soirée,

Cordialement

nicolas
Invité
nicolas

bonjour

j’ai bien installé le module, c’est tres bien merci.

petite question, y a t’il moyen de faire le g-bandeau avec la description avec des caracteres plus grands ou une autre police couleuretc …??

merci.

Trephisto
Invité
Trephisto

Salut à tous,

Merci beaucoup maniT4c pour ce superbe module!!

Je voulais savoir si il y avait par hasard une mise à jour de prévu? Car je suis en train de développer un multiboutique et j’aimerais pouvoir avoir un slide différent sur chaque boutique. Ou le même slide mais y mettre différentes images en fonction de la boutique.

Merci d’avance pour ta réponse!

Trephisto
Invité
Trephisto

Ok, merci pour ta réponse.

Si j’arrive à le modifier pour que ça fonctionne en multi boutique, je te soumettrai mes modifs.

A bientôt ;)

Trephisto
Invité
Trephisto

Bon, j’ai essayé d’ajouter la gestion des boutiques mais malheureusement, je ne connais pas encore assez bien Prestashop et la programmation orientée Objet pour arriver à mes fins.

J’ai trouvé quelques pistes, effectivement ça n’a pas l’air très compliqué mais je n’arrive pas à tout bien faire correctement. Du coup je vais essayer d’être patient :D

lalapresta
Invité
lalapresta

Bonjour maniT4c
Merci pour toutes ces informations. Avez-vous eu le temps de modifier le slider et le rendre compatible avec Presta 1.5.4.1.
Et aussi, pourra-t-il aller avec mon theme Elation-Liquid qui est responsive. Je suis plutôt débutante et ne m’aventure pas trop dans les réglages pointus…

prestacomic
Invité
prestacomic

Bonjour,

J’aime beaucoup ce module, aucun problème selon les navigateurs et pas de soucis pour les versions 1.5.* de Presta.

Par contre, d’autres modules (pas un des tiens ^^) donnent la même erreur lorsque l’on tente de les installer : “Exception : Property Tab->name is empty”.

Pourrais-tu m’indiquer comment tu as corrigé ce problème afin que je fasse les modifications nécessaires sur ces modules ?

Merci beaucoup !

prestacomic
Invité
prestacomic

D’abord merci pour cette reponse rapide !

Effectivement, c’etait bien l’erreur, maintenant ca fonctionne bien.
Si ce n’est qu’une autre exception du meme type apparait quelques lignes en dessous : ” Exception : $stockmvtreason->name is empty ”

Enfin, j’imagine que c’est le meme genre de probleme que precedement, je vais voir cque je peux faire.

Merci encore en tout cas pour ton aide (precieuse) !

PS : Désolé pour le spam sur le blog ^^

prestacomic
Invité
prestacomic

C’est résolu, merci !

Christian
Invité
Christian

Bonjour.

Tout d’abord félicitation pour ce module, il est génial.

Ensuite j’aurais une question.
Je veux que le module s’affiche sur toutes les pages de mon site, malheureusement il ne s’affiche pas sur les pages du genre “Contact” ou “Mon compte”.
J’ai regardé un peu dans le code mais je ne sais pas où peut être situé la ligne qui n’affiche pas le module.
As-tu une idée ?

Merci d’avance

Christian
Invité
Christian

D’accord.

Je te remercie de ta réponse.
Je vais faire les modifications en conséquences alors.

Bonne continuation.

Sébastien
Invité

Bonjour,

Merci pour le module qui est top. Cependant j’ai un petit souci je viens de mettre en ligne ma boutique (en local tout fonctionnait parfaitement) et les liens URL en rapport avec les images sont restés ceux de la version locale. Et lorsque je veux les changer pour mettre le bon lien, le module ne les sauvegarde pas on dirait, ce sont toujours ceux de la version locale qui sonnt présents.

Une idée peut-être ?

p.s : mes capacités en informatique sont très limitées :-)

Merci d’avance !

Dan
Invité
Dan

Ce slideshow est une merveille.
J’en profite pour dire mon admiration pour le travail d’Olivier. Toujours simple et efficace. La simplicité se fait hélas si rare sur la toile.
Je suis Freelance aussi (proche de la retraite !) mais pas du tout spécialisé Prestashop. Je ne perds pas de vue tes publications, je vais en avoir besoin !
Cordialement ;-)

Loguste
Invité

Bonjour,

Sur quel fichier faut-il intervenir pour ouvrir le lien choisi pour l’image du slideshow dans une autre fenetre.

Par avance merci.

Bravo pour ce module

PrestaShop™ 1.6.0.9
Op’art slideshow v1

vendugeek
Invité

Bonjour,

je suis sur prestashop 1.6, j’essaye d’installer le slider mais en sauvegardant j’ai eu cette page :

[PrestaShopException]

Property MyImage->name is empty
at line 878 in file classes/ObjectModel.php

872.
873. $message = $this->validateField($field, $value, $id_lang);
874. if ($message !== true)
875. {
876. if ($die)
877. throw new PrestaShopException($message);
878. return $error_return ? $message : false;
879. }
880. }
881. }
882.

ObjectModelCore->validateFieldsLang – [line 296 – classes/ObjectModel.php]

•ObjectModelCore->getFieldsLang – [line 480 – classes/ObjectModel.php]

•ObjectModelCore->add – [line 21 – modules/opartslideshow/models/MyImage.php] – [2 Arguments]

•MyImage->add – [line 417 – classes/ObjectModel.php] – [2 Arguments]

•ObjectModelCore->save – [line 420 – modules/opartslideshow/controllers/admin/AdminSlideshowImageController.php]

•AdminSlideshowImageController->postProcess – [line 171 – classes/controller/Controller.php]

•ControllerCore->run – [line 373 – classes/Dispatcher.php]

•DispatcherCore->dispatch – [line 54 – admin/index.php]

Que faut-il faire svp ?

Merci

vendugeek
Invité

Oui c’est bien cela génial ça marche !

En installant votre slider mon bug de liens qui disparaissaient dans mon footer s’est réglé tout seul !

Merci beaucoup :D

wpDiscuz